Back to overview
Issue with customer billing
Sep 23 at 10:53am EDT
Affected services
User Dashboard
Signup
Resolved
Sep 23 at 10:53am EDT
Our payment processor is currently experiencing issues with processing credit card payments. We are working with them to resolve this issue and will post here when we have updates.
Affected services
User Dashboard
Signup